Excel / Calc - Données - RechercheV

Dans ce classeur 4 feuilles:

  • Le fichier client utilisé précédement
  • Un fichier produits contenant les titres de la série des Bob Morane
  • Une feuille Devis que nous allons compléter
  • Une feuille pour les frais de gestion

Débutons par la partie Client de la feuille Devis

RechercheV

clients

La cellule E5 contient le code (B2) d'un client (Claudio Durant). Ce code, associé à la feuille des clients va permettre de faire afficher les informations de ce client dans les cellules E6 à E11 de la feuille Devis. La fonction RECHERCHEV le permet et se trouve dans le menu ou bandeau Données. On place le curseur en E6::

RechercheV demande à renseigner 4 items:

  • Critère de recherche: ici le code client saisi donc E$5, $ pour figer la ligne et recopier la fonction ver le bas, vers E11
  • Matrice: tout le ficher de la feuille client soit ici $Table_clients.$A$3:$L$23.
  • Indice ou N° COL: le numéro de la colonne retournée (Cf ci-dessous) soit 2 pour avoir la civilité qui figure dans la seconde colonne
  • Recherche dans une plage triée: FAUX ou 0 pour indexer le bon code client.

D'où la formule suivante: =RECHERCHEV(E$5;$Table_clients.$A$3:$L$23;2;0)

En recopiant vers le bas si les $ sont bien positionnés il suffit de mdifier le numéro de colonne retournée, soit:

=RECHERCHEV(E$5;$Table_clients.$A$3:$L$23;3;0)
=RECHERCHEV(E$5;$Table_clients.$A$3:$L$23;4;0)
=RECHERCHEV(E$5;$Table_clients.$A$3:$L$23;5;0)
=RECHERCHEV(E$5;$Table_clients.$A$3:$L$23;6;0)
=RECHERCHEV(E$5;$Table_clients.$A$3:$L$23;7;0)

On obtient donc:

  

Tout changement de code client en E5 permet de modifier les information des cellules E6 à E11 Tout code n'existant pas entraîn e message d'erreur ci-dessus.

Produits

Positionnons nous en B16 at activons RechercheV pour récupérer les informations sur les titres commandés:

Les items à renseigner:

  • Critère de recherche: ici le code ouvrage saisi donc $A16, $ pour figer la ligne et recopier la fonction ver le bas, vers E11
  • Matrice: tout le ficher de la feuille produits soit ici $Table_titres.$A$1:$G$94.
  • Indice ou N° COL: le numéro de la colonne retournée (Cf ci-dessous) soit 3 pour avoir le titre qui figure dans la troisième colonne
  • Recherche dans une plage triée: FAUX ou 0 pour indexer le bon code client.

D'où: =RECHERCHEV($A16;$Table_titres.$A$1:$G$94;3;0)

Pour les celulles C16 à G16 il suffit de recopier et de modifier l'item Indice ou N0 colonne
=RECHERCHEV($A16;$Table_titres.$A$1:$G$94;2;0)
=RECHERCHEV($A16;$Table_titres.$A$1:$G$94;4;0)
=RECHERCHEV($A16;$Table_titres.$A$1:$G$94;5;0)
=RECHERCHEV($A16;$Table_titres.$A$1:$G$94;6;0)
=RECHERCHEV($A16;$Table_titres.$A$1:$G$94;7;0)

On a alors:

Recopions les cellules B16 à G16 vers le bas:

La saisie des quantités permet de terminer le bon de commande.

Fichiers utilisés

LibreOffice CALC

MS Excel

Aristeri.com est le site de Bernard Andruccioli - 05 56 00 95 93 - Mentions légales -
/?rubrique=Excel_donnees_2